PHP 5.4 Is Available Now On All Shared Servers!

php-logo

In our continuing effort to provide our customers with the most up to date software platforms, HostNine would like to announce the immediate availability of PHP 5.4 on all shared servers.

The use of PHP 5.4 is alongside that of the default PHP 5.3 stack, and no customers will be forced to use 5.4 unless they explicitly enable it themselves, or request it from Technical Support.

HostNine provides you the control and option of enabling PHP 5.4 on your entire account or on a per-directory basis through a simple .htaccess modification. This modification can be placed in an accounts public_html/.htaccess file to enable PHP 5.4 for an entire account or in the .htaccess file of a specific directory to enable PHP 5.4 under that directory tree only.

To enable PHP 5.4, you must add the following htaccess option:

AddType application/x-httpd-php54 .php

The binary path to the PHP 5.4 installation, should you require it for executable php scripts or cronjobs, is located at:

/usr/local/php54/bin/php

As with the existing PHP 5.3 setup that defaults on our servers, when you enable PHP 5.4, it will respect any custom php.ini settings you may have under your account. In addition, all standard PHP modules and extensions from the existing PHP 5.3 setup are default enabled in the PHP 5.4 setup to ensure the best compatibility possible.

Please note that Zend encoded files are not supported on PHP 5.4, as Zend has yet to distribute a compatible decoder extension for PHP 5.4. However, we do include support for IonCube encoded files in PHP 5.4.

The PHP 5.4 installation will be maintained alongside our default PHP 5.3 installation on all servers going forward, to ensure that it receives version updates, bug fixes and security patches in a timely fashion.

Check out HostNine’s SharedResellerCloud ResellerVPS, or Dedicated hosting plans!